Cannot create new Users



Hello everybody,

i just found this FBA Pack just before we were buying a solution. But I always run in a problem, when i try to create a new User.

I allways get the following error:

"Object reference not set to an instance of an object."

Correlation ID:

Date and Time:


In the Log File in the Web Server Extension Folder, I can't find anything useful.

I read that this problem can occure when the Password doesn't reach the minRequiredPAssworLength. Where can I check this?


Is this with the user management page, or the membership request web part?

Is the site already setup for FBA and can you login via FBA?

My guess would be that this has to do with your SharePoint FBA configuration.  Check through here to make sure all is setup properly:


- Its the User Managment Page

- Site is already configured for FBA and everything works fine, another solution has also worked fine until the trial expired.

- If i understand the FBA Documentation correct, the Site is Setup for Windows and for SQL Auth.

My Site is only allowed for SQL Auth. Could this be the problem?


SQL Auth only should be ok.

Can you find the same error in your log file? It should have the full stack trace that will tell me where in the code it is failing, so I could probably give you a better idea what to check.

Can you try the membership request web part, and the other web parts and see if they work.  How about creating a Role?

Also, maybe try to remove and redeploy.  Probably won't fix anything, but can't hurt to try.

In the next version i'm going to add a page to check the configuration to help troubleshooting these types of issues.


Ah, I think I know now whats the Problem was.

I tried to create a test account with the same E-Mailadresse as my first account.

The Web Part tells me this error, but the Member Management Page runs always in the same error with Object reference.


But now with the new Accounts i can not log in. So I will have to go on some testing


Glad you found the problem.  There's actually already an issue raised for that bug. It will be fixed in the next release.