SharePoint 2019 - Issues to access user creation page


Hi, I have an issue on SharePoint 2019. Everything is fine during the installation/configuration, but after the feature activation, when I try to go go “FBA User Management” (/_layouts/15/FBA/Management/UsersDisp.aspx) from the site settings, I got the error “this site isn’t shared with you” (even with site coll admin, or farm admin, or anyone else). In logs I see “Unexpected Failed to assert permission mask.”, “Acces denied” , “PermissionMask check failed for {7BC14BFC-B4EF-4C55-A87F-405FD07E58F0}. Asking for 0x08000000, have 0x00000000”, “PortalSiteMapProvider was unable to fetch root node, request URL: /_layouts/15/FBA/Management/UsersDisp.aspx”. I don’t understand why … I have to mention that my web app has 2 zones (1 default with claims, 1 internet with FBA activated) and I try to create users from defaul zone (since I have for now 0 FBA users). My site collection is in the new moder experience (don’t know if it can cause problems). Can you help me ? Thank’s in advance.


I’ve tested with the modern view, so that shouldn’t be an issue. I haven’t seen this error before. It certainly sounds like a permission problem - but if you can see the FBA User Management link in Site Settings, you should have permissions to it. The only thing I can think is that maybe it’s being accessed from the wrong context - for example maybe you have permissions to /sites/mysitecollection, but not the root site collection, and the url is taking you to the wrong location for some reason. When you click the FBA User Management link, see if the root of the link changes from the site settings url. ie if you are in:
you should go to:

Do you have permission issues elsewhere in SharePoint? Or just with the FBA Pack management pages?

If it’s just with the FBA Pack, the only other thing i’d suggest is to retract it and redeploy from Central Admin - Farm Solutions.


Hello Alex,

We upgraded from sharepoint 2016 to 2019, with FBA custom membership provider, and we are facing the same error “Failed to assert permission mask”. Can you please advise if you found any solution?

Mohamed Ramadan


I had a similar issue, changing the application pool user using central administration solved