The site could not be found


I have been working on this for a few hours and can't figure out the disconnect.

Right now I am getting the follow error when trying to deploy to "http://fbatest/" The Site ........ could not be found in the web application SPWebApplication Name=FBATest.

Good news is this is a slightly different error from the previous ones. Bad news it is still an error :)

I have tried running the deploy on other web applications without success. I have also ran the deploy without any url specified and it appeared to have work and I can even enable it in the site collection features. However when I tried to click on FBA Site configuration I get "The resource object with key 'SiteConfig_Title' was not found. I get the same not found error on the other three links as well. I have ran .\undeploy and then ran .\deploy again and get the same error.

Any feedback would be appreciated. Thanks.

The url you put in the command line needs to be the url to your site collection. So if the url is http://fbatest/sites/fbatest, that's what you need to use. Leaving it out will also work, you just need to enable it in Site Collection features like you mentioned.

The errors you're getting sound like it's not deployed properly to that web application. Use central admin to check the status of the deploy of the solution under 'Farm Solutions'. Also try using the farm solutions page to undeploy + redeploy it to the web application in question and see if that resolves the issue.