Cannot Deploy 1.2.0 Solution

sharepoint2010
codeplex

#1

I have undeployed the 1.1.0 solution and when attempting to deploy the 1.2.0 solution I am getting the following Powershell error. Enable-SPFeature : The Feature is not a Farm Level Feature and is not found in a Site level defined by the URL.

So I tried to upload the wsp solution file to the Soluion Gallery but then could not activate it. I received the following error message

Error

This solution contains invalid markup or elements that cannot be deployed as part of a sandboxed solution. Solution manifest for solution '956715d5-f34c-4b00-bfb7-8c35d5fa0f62' failed validation, file manifest.xml, line 3, character 4: The element 'Solution' in namespace 'http://schemas.microsoft.com/sharepoint/' has invalid child element 'ApplicationResourceFiles' in namespace 'http://schemas.microsoft.com/sharepoint/'. List of possible elements expected: 'FeatureManifests, Assemblies, ActivationDependencies' in namespace 'http://schemas.microsoft.com/sharepoint/'.

Any suggestions?


#2

From the sounds of the first error message, you deployed it using the wrong url. Make sure the url you specify is the site collection you want to activate it on.

As for uploading the wsp solution file, it's not a sandboxed solution, so you can't deploy with this approach.  If you want to do a manual deploy, see here:

http://technet.microsoft.com/en-us/library/cc262995.aspx


#3

We were deploying it to the correct site collection URL. We also tried to deploy it manually and that failed as well. Any other suggestions?

 Thank you,

Kevin


#4

Not really.  The initial deploy failure was at enable-spfeature - which means it was probably successfully added and deployed - you probably just have to activate it in the Site Collection features list.

When you did a manual deploy, what error did you get?


#5

The feature does not show up in the Site Collection Features list to activate.

 

Here is the output from the manual deployment:

PS C:\> add-spsolution c:\installsfixes\Sharepoint2010FBAPack.1.2.0\Visigo.Share

point.FormsBasedAuthentication.wsp

 

Name SolutionId Deployed

---- ---------- --------

visigo.sharepoint.formsbase... 956715d5-f34c-4b00-bfb7-8c35d5fa0f62 False

 

 

PS C:\> Install-SPSolution -identity Visigo.Sharepoint.FormsBasedAuthentication.

wsp -AllWebApplications -GACDeployment

PS C:\> Enable-SPFeature -Identity FBAManagement -URL http://(sitecollectionurl)/

Enable-SPFeature : The Feature is not a Farm Level Feature and is not found in

a Site level defined by the Url http://(sitecollectionurl)/.

At line:1 char:17

+ Enable-SPFeature <<<< -Identity FBAManagement -URL http://(sitecollectionurl)/

+ CategoryInfo : InvalidData: (Microsoft.Share...etEnableFeature:

SPCmdletEnableFeature) [Enable-SPFeature], SPCmdletException

+ FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletEnableFe

ature

 

PS C:\>

 

Do you have any other suggestions?

 

Thank you,

Kevin


#6

Not really. My guess is still that there's something wrong with the url you specify for the site collection. Maybe multiple urls for the machine and SharePoint is only setup to recognize one of them?

http://sharepoint.stackexchange.com/questions/12581/problem-installing-web-part-using-powershell

Or maybe a permissions issue - is the user you're running the PowerShell script with an administrator on the site collection?

As long as the add-spsolution command worked (and it looked like it did) you should be able to do the deploy to the web application from central admin. And as long as that works, you should be able to enable the feature on the settings page for the site collection.

Maybe try downloading it again and deploying with the new download (really grasping at straws here though, I doubt that's the problem)


#7

Maybe try the deploy on another SharePoint server if you have one - maybe there's something funky with the current installation. Or more likely something funky with the web application or site collection you're installing to.  Maybe try creating a new web application + site collection.


#8

Hi,

 

What exactly do you mean by “you should be able to do the deploy to the web application from central admin”?  

 

Thank you,

Kevin


#9

You can only add solutions from PowerShell, but the rest of the steps can be done interactively via the web interface. Read the link I sent you in my first reply - it has the steps to deploy from Central Admin.