Errors when attempting to deploy the pack



I tried to deploy the pack to a web application with FBA enabled.  I got some errors, then the deployment process got stuck for several minutes on Waiting to finish job solution-deployment-visigo.sharepoint.formsbasedauthentication.wsp-0. I canceled the process, opened up the file, and removed that function call. And now, I'm getting the following errors:

Going to disable feature
Disable-SPFeature : The Feature is not found. Provide a Guid and -Force parameter then try again.
At C:\Users\joes\Desktop\Sharepoint2010FBAPack\UnDeploy.ps1:35 char:19
+     disable-spfeature <<<<  -identity $featureName -confirm:$false -url $url
    + CategoryInfo          : InvalidData: (Microsoft.Share...tDisableFeature:SPCmdletDisableFeature) [Disable-SPFeature], SPCmdletException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletDisableFeature

Going to uninstall feature
Uninstall-SPFeature : Cannot find a Feature object with Path or Id: FBAManagement in scope Local farm.
At C:\Users\joes\Desktop\Sharepoint2010FBAPack\UnDeploy.ps1:38 char:21
+     uninstall-spfeature <<<<  -identity $featureName -confirm:$false -force
    + CategoryInfo          : InvalidData: (Microsoft.Share...ninstallFeature:SPCmdletUninstallFeature) [Uninstall-SPFeature], SPCmdletPipeBindException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletUninstallFeature

Going to uninstall solution
Uninstall-SPSolution : Cannot uninstall the LanguagePack 0 because it is not deployed.
At C:\Users\joes\Desktop\Sharepoint2010FBAPack\UnDeploy.ps1:41 char:22
+     Uninstall-SPSolution <<<<  -identity $solutionName  -allwebapplications -confirm:$false
    + CategoryInfo          : InvalidData: (Microsoft.Share...installSolution:SPCmdletUninstallSolution) [Uninstall-SPSolution], SPCmdletException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletUninstallSolution

Going to remove solution
Remove-SPSolution : The solution cannot be removed when a job is scheduled or running.
At C:\Users\joes\Desktop\Sharepoint2010FBAPack\UnDeploy.ps1:44 char:19
+     Remove-SPSolution <<<<  -identity $solutionName -confirm:$false
    + CategoryInfo          : InvalidData: (Microsoft.Share...tRemoveSolution:SPCmdletRemoveSolution) [Remove-SPSolution], InvalidOperationException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletRemoveSolution

Going to add solution
Add-SPSolution :  A solution with the same name "visigo.sharepoint.formsbasedauthentication.wsp" or id "956715d5-f34c-4b00-bfb7-8c35d5fa0f62" already exists in the solution store.
At C:\Users\joes\Desktop\Sharepoint2010FBAPack\Deploy.ps1:35 char:15
+ Add-SPSolution <<<<  $solutionPath
    + CategoryInfo          : InvalidData: (Microsoft.Share...dletAddSolution:SPCmdletAddSolution) [Add-SPSolution], ArgumentException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletAddSolution

Going to install solution to all web applications
Install-SPSolution : A deployment or retraction is already under way for the solution "visigo.sharepoint.formsbasedauthentication.wsp", and only one deployment or retraction at a time is supported.
At C:\Users\joes\Desktop\Sharepoint2010FBAPack\Deploy.ps1:38 char:19
+ Install-SPSolution <<<<  -identity $solutionName -allwebapplications -GACDeployment
    + CategoryInfo          : InvalidData: (Microsoft.Share...InstallSolution:SPCmdletInstallSolution) [Install-SPSolution], InvalidOperationException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletInstallSolution

Going to enable Feature
Enable-SPFeature : The Feature is not a Farm Level Feature and is not found in a Site level defined by the Url http://2008sharepointh:33608/.
At C:\Users\joes\Desktop\Sharepoint2010FBAPack\Deploy.ps1:41 char:17
+ Enable-spfeature <<<<  -identity $featureName -confirm:$false -url $url
    + CategoryInfo          : InvalidData: (Microsoft.Share...etEnableFeature:SPCmdletEnableFeature) [Enable-SPFeature], SPCmdletException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletEnableFeature

I tried to run the undeploy to clean up, but got similar errors. I created a new web application, also with FBA enabled. When I ran the deploy script against that application, I got the above errors, too.

What can I do to clean up the errors and deploy the FBA pack?


From the error message, it looks like the deployment got added to the list of timer jobs, but was not executed by the timer.  There's a function in the deployment process that waits until the job has been run before continuing.  It can sometime's take a while before the job's been run, but it usually finishes for me within a minute.

Likely there's either a long running timer job already running, that's backing things up (You can see the Timer job status in Central Admin), or your Timer service isn't running and nothing's being processed.

Once the Timer is processing jobs properly, rerun the deploy script (put the function call back in!) and it should fix everything up.


Thanks for the quick reply!

I've verified that the SharePoint 2010 Timer service is running. There aren't any running jobs in Central Admin. I restarted the deploy process (with the function back in) and it's now on its 11th row of dots. Admittedly, the server is painfully slow, so I'll just let it keep chugging for a while longer.


That does sound really slow.  Have you looked at it in the Timer Job status in central admin to verify that it's queued up or currently being processed?


Yes, I've looked.  I don't see anything relevant in the Scheduled or History sections, and the Running section is completely empty.


Strange. Why don't you try to manually install the wsp, and see what happens?


I was able to install it manually.

Thanks for your help!


I managed to reproduce your problem.  The deployment script fails and the timer job aborts if the Sharepoint 2010 Administration service is not running.  The aborted timer job also prevents the deployment scripts from succeeding in the future, until the aborted timer job is deleted.  To fix the problem I've updated the deployment scripts to delete an existing deployment timer job before continuing.  The updated deployment scripts are in release 1.0.1.