FBA Pack for 2010 to work on SP2013

Hi! I have been scratching my head here. I upgraded to SP2013 (as we are moving to a new platform and this was to buy time…) I installed the 2010 FBA pack and I believe it was working. Now - am getting this error for new user registrations -

System.IO.FileNotFoundException: Could not load file or assembly ‘Microsoft.SharePoint.IdentityModel, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c’ or one of its dependencies. The system cannot find the file specified. File name: ‘Microsoft.SharePoint.IdentityModel, Version=, Culture=neutral, PublicKeyToken=71e9bce111e9429c’
at Visigo.Sharepoint.FormsBasedAuthentication.MembershipRequest.ApproveMembership(MembershipRequest request, SPWeb web)
at Visigo.Sharepoint.FormsBasedAuthentication.MembershipRequestControl.b__0()

We had other custom web parts (like a logon web part) that we had to update with the v15 identity model. Is this what I have to do or is something else a miss here? ALL items work except new user registration does not move them to the specified group (for those not needing approved) and if we have approval set - changing to approved does nothing. The email for new users (pending) is going out, but not when they are approved. Password change request emails are flowing as well. Yes, when we have the password option for them to create their own off - no email with the auto password. (As a result - no new user can logon unless we manually add them into SP and then also add them to the visitors group.)

I have been banging my head on this for two days. :frowning:

Thanks all!

You do need to install the SharePoint 2013 FBA Pack on SharePoint 2013. SharePoint 2010 FBA Pack is incompatible with SharePoint 2013.

Oddly it was working (keeping in mind we are not upgrading any of these sites to 2013 so they are visually staying 2010.) Ugh… Ok well I tried to remove the FBA 2010 pack and it is as if the sites will nto release it thus 2013 will not deploy. IDK what is going on.

Thanks for the quick reply!!

Yeah - i tried removing all traces of all FBA web parts and the 2013 will not deploy. :frowning: I am not sure what to do.

and you’re running .\deploy.ps1 from powershell? Is it showing any errors?

Hi - i did figure it out. I had to remove all traces of the FBA pack; then we recompiled the solution and was able to successfully deploy!

Thank you!!!