Installation issue - Feature not available

Hi there!

I've been trying to install the Sharepoint 2010 FBA Pack version 1.1.0 to my server, but I keep receiving the following errors in the deploy command:

Solution not installed
Going to add solution

Name                           SolutionId                           Deployed
----                           ----------                           --------
visigo.sharepoint.formsbase... 956715d5-f34c-4b00-bfb7-8c35d5fa0f62 False
Going to install solution to all web applications
Waiting for job to finish
Waiting to finish job solution-deployment-visigo.sharepoint.formsbasedauthentica
tion.wsp-0.Finished waiting for job..
Going to enable Feature
Enable-SPFeature : The Feature is either not found or not a Farm Level Feature.
 Use Url parameter to specify the scope of the Feature.
At C:\Users\malegretti\Downloads\SharePoint2010FBAPack.1.1.0\Deploy.ps1:56 char
+ Enable-spfeature <<<<  -identity $featureName -confirm:$false -url $url
    + CategoryInfo          : InvalidData: (Microsoft.Share...etEnableFeature:
   SPCmdletEnableFeature) [Enable-SPFeature], SPCmdletException
    + FullyQualifiedErrorId : Microsoft.SharePoint.PowerShell.SPCmdletEnableFeature

 Already tried the command passing the URL parameter, with the same results.

The server is a 2008R2, running Sharepoint Server 2010 (the Timer and Administration services are started, I've already double checked that). After the unsuceeded deploy command, I can see the solution in Central Administration, but it's not deployed anywhere. If I list the features with the Get-SPFeature command, the feature FBAManagement that the deploy script seem to expect is not listed, so I can assume that somehow it wasn't installed with the solution. The feature Visigo.Sharepoint.FormsBase... is listed under farm features.

Any light in this issue?

It looks like it doesn't recognize the site collection specified.  What syntax are you using for the deploy command? The url needs to point to your site collection you're deploying to, like this:

.\deploy http://demo2010a:13824/

The url is only used to enable/disable the feature in the site collection, so if you get this error, the rest of the deploy should have worked and you can manually enable the feature in your site collection.

ccoulson, thanks for the prompt response!

I've tried with

.\deploy (which I assume would enable the feature in all site collections)



, both with the same results. To me it seems that the feature doesn't get installed, somehow - it doesn't get listed in the get-SPfeature, and it doesn't show up in the list of features that can be enabled in my site collections.


On my setup, I have to use the internal server url for it to automatically authenticate - maybe try that?  

 If you continue to have problems, try a manual deploy: