SharePoint Subscription deploys FBA Pack to 15 Hive!

I have deployed FBA 2016-2019 to SharePoint Subscription (on premise of course). It works in the fact that FBA users are able to log in from my SharePoint 2013 aspnetdb database restore to SSE, however the FBA menu options are not visible in Site Settings of my new SSE Site Collection. I looked at my 2013 deployment and it is in the 15 Hive so I expected my SSE to be in the 16 Hive but it’s not. I can get to the FBA User Management page via /_layouts/15/FBA/Management/UsersDisp.aspx in SSE. This is weird in my opinion.

This also leads to the fact that I cannot UnDeploy the Visigo FBA Pack solution either. It just hangs with … forever. I suspect that the UnDeploy is looking to remove it from the 16 Hive when it’s in the 15 Hive. I also have no idea where to see the 15 Hive on SSE as I can only see a 16 folder!

I’m hoping that someone can help me with this. Thanks.

I think what’s happening with the FBA menu options is that you’re running a modern site, which doesn’t support classic web parts (or menu items). You’ll find they work on classic sites and other non-modern places like the Site Settings pages.

With the update from 2013 to 2016, only the assemblies had to be changed to reference v16. The hive stayed the same. Explained here:

Also, I haven’t had any issues with retracting and removing the solution. Did you try via Central Admin Solution Management? Is your SharePoint Timer Service and SharePoint Administration service running?

Thanks for the quick reply! I can get around the FBA User Management by displaying it in a Link List on the main root site in a Webpart, which only Admins of the company have access to. This is the only place it really needs to be seen anyway! That said, it should show up in Site Settings but it does not show up in the root site, or the other 2 site collections. The sites are all Teams (classic) from what I recall since I migrated from SharePoint 2013 Foundation using ShareGate and ShareGate said it could not use a _Blank template so it would use a Teams (classic) template instead. So this is kind of still an issue but I do have a work around.

The retraction still hangs, even from Central Admin. I have checked the LOGS and there are no errors for Visigo. The only Exception is “Unexpected Exception in SPDistributedCachePointerWrapper”, but I don’t think that has anything to do with the retraction. The only option I have is to Cancel Retraction, which it does immediately. It would be nice to know why I can’t retract the solution, just in case there is a new release in the future.

Do the FBA Pack Settings menu/pages show up for portal administrators in site settings? If not, are you sure the solution is deployed to that Web Application, and the Forns Based Authentication Management feature is enabled on the site collection?

As long as the timer service and sharepoint administration service are running, I’m not sure why the retract isn’t working. Does it work for other solutions?

The 3 FBA menus do not show up in the Site Settings. Yes, the FBA solution is deployed to the web application and central admin. I know I don’t need it in CA but I deployed it there anyway and now I can’t undeploy it from anywhere. I tried creating a new Web Application, hoping it would show up, but it does not. The image below shows it deployed to CA (port 2022) and the only Web Application I have on port 444, which uses my wildcard * Rapid SSL certificate. I’m using the same certificate on my SP 2013 VM as well, where I’m testing the migration from. There is no problem with the 2013 installation. It’s just the 2022 - SSSE version that’s the problem.


*Image removed due to New User limitation.

FBA is configured and it does work! I can add users as site collection administrators using the people picker in CA or even just type them in and it works. I even have a separate IIS app so I can test the connectivity to the FBA database and all is good, I can see all users plus I can add or delete any! I can access the FBA User management form via the link in my previous post but I have to get there on my own as Site Settings is not displaying it.

This image shows the FBA configuration, including my own custom login that I have been using since SP 2010.
*Image removed due to New User limitation.

As you can see here the 3 FBA Menus are missing from Site Settings. I have tested with 2 different FBA users, both as site collection administrators and neither display the FBA menus.
*Image removed due to New User limitation.

As for the question, can I retract other solutions. Well the answer is NO. I have tried retracting 2 other solutions. One is a custom one I wrote and the other is a 3rd party web part. So I guess this problem is my problem but I have no idea how to overcome this issue. I’ll have to Google it. Sorry, this is not an FBA Pack issue by the looks of it! It’s on me to fix this, but any suggestions are very welcome.

The server is a Hyper-V (on Server 2019) VM running Windows 2022, SQL 2022 with the following installed below.
*Image removed due to New User limitation.

So the bottom line is that this is a test environment and maybe my resources are not correct on the Hyper-V as it does seem quite slow, causing these issues. I will hopefully have the proper VM’s (TEST and PROD) ready in the next 2 weeks, where the real work will happen. I just had to do this exercise for my client to prove that the classic web parts will work in the new SSSE, and they do, bar some 15/16 classic/modern issue that I discovered and have to also resolve.

Thanks again for your time. I don’t think you can help me much but if you can it was be very welcome.
PS, I tried to post this but I’m limited to 1 image as a new user, so I’ll just post another post below with all the images in 1 so you can see.

These are the images that I could not post in the over post due to limitations.

I’m guessing the menu’s aren’t there because of either the failed full installation or perhaps this stuck solution retraction (I’m guessing the ‘Forms based authentication management’ feature isn’t in the site collection feature list?). Probably best is to figure out what’s going on with the retraction and then attempt to deploy again. Just a note the FBA Pack is not supported in Central Admin, only in standard SharePoint site collections - though I doubt that is what’s causing your retraction issues.

You might want to look at the timer jobs (under monitoring in central admin) - the jobs for the installation and retraction of the solutions will be there, and might give some clue as to why they are failing.

You can also try using the ‘force’ parameter of remove-spsolution to try and clean them up before attempting to install them again.

1 Like

Thanks for the information. I’ll have to get back to this later in the week. I’ll definitely post my findings.

Just for some further information, you are correct, the Forms Based Authentication Management feature is NOT in the Site Collection Features either, under Site Settings → Site Collection Administration → Site Collection features. (_layouts/15/ManageFeatures.aspx?Scope=Site). I just wanted to provide this information. I’m still investigating the issue and will post more when I know.

OK, I now have it working in my environment, plus my web parts can now be deployed and retracted as required without them hanging. This is 3rd party, my own custom written web parts and the Visigo SharePoint2016-2019FBAPack.1.3.6 Web Part. Initially I use the ps1 files that came with the Visigo package to Deploy the FBA Pack but something caused the FBA Pack not to show up in the Site Settings, or maybe I was blind. Anyway, this time I Deployed using the PowerShell below, then I deployed to the web applications I wanted. One Teams and one Teams (classic). Finally I went into Site Settings → Site Collection Administration → Site collection features and there I activated Forms Based Authentication Management, which was not there before. All of the FBA menus now appear in Site Settings! Just to test, I retracted and deployed Visigo one last time and everything still works.

This was my solution. Get-SPSolution just confirms that it was deployed initially.

Get-SPSolution (Get a list of all reployed Solutions)
Remove-SPSolution Visigo.Sharepoint.FormsBasedAuthentication.wsp -force
Add-SPSolution -LiteralPath C:\Development\WebPartsSSSE\SharePoint2016-2019FBAPack.1.3.6\Visigo.Sharepoint.FormsBasedAuthentication.wsp
Install-SPSolution -Identity Visigo.Sharepoint.FormsBasedAuthentication.wsp -WebApplication https://mySSLSharePointSite -GACDeployment -Force

I used the same script above to “fix” all the other solutions (web parts) that would not retract. Now I’m a happy camper.

Thanks for all your replies.
Dave Stuart

Great to hear you got it working!